


LabVIEW je grafički programski jezik.

Za razliku od programskih jezika čija sintaksa je zasnovana na tekstu
LabVIEW koristi blokove umesto linija teksta.

Kod programa je dijagram koji se sastoji od čvorova i žica.

LabVIEWLabVIEW

Kod programa je dijagram koji se sastoji od čvorova i žica.
Podaci “putuju” preko žica.
Tok izvršavanja programa zavisi od protoka podataka, a ne Tok izvršavanja programa zavisi od protoka podataka, a ne koda!koda!
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Kod programa je dijagram koji se sastoji od čvorova i žica.
Podaci “putuju” preko žica.
Tok izvršavanja programa zavisi od protoka podataka, a ne Tok izvršavanja programa zavisi od protoka podataka, a ne koda!koda!

Novi način razmišljanja: datadata flowflow umesto codecode flowflow (chart flowchart flow)!!

Vodeći princip: čvor ne izvršava svoju funkciju sve dok podaci, preko 
žica, ne “stignu” do ulaza u isti.



LabVIEWLabVIEW

LV programi se zovu virtualni instrumenti jer svojim izgledom 
podsećaju na fizičke instrumente, kao npr. osciloskope i multimetre. 

Ekstenzija programa pisanih u LV
*.vi (virtual instruments)



LabVIEWLabVIEW

LV programi se zovu virtualni instrumenti jer svojim izgledom 
podsećaju na fizičke instrumente, kao npr. osciloskope i multimetre. 

Ekstenzija programa pisanih u LV
*.vi (virtual instruments)

 Zbog prvenstvene primene kao mernih virtuelnih uređaja, LV sadrži 
bogate biblioteke gotovih funkcija za kontrolu mernih instrumenata, kao 
i za prikupljanje, analizu, prezentaciju i skladištenje podataka.



Zašto koristiti LabVIEW?Zašto koristiti LabVIEW?

Jednostavan za učenje

Jednostavan za primenu

Programski kod je u vidu šeme

Nema sintakse!!!

Jednostavno i brzo ispravljanje grešaka 

Prilagodljiv



Inicijalni prozor

Pokretanje LabVIEW programa

Početak:

Pokretanjem NI LabVIEW programa pojaviće se NI LabVIEW inicijalni prozor

1. Iz novog dokumenta:
New»Blank VI

VI from Template

2. Iz postojećeg primera:
Examples»Find 

Examples…

ili



LabVIEW programLabVIEW program
Svaki LabVIEW program (*.(*.vi) se sastoji iz dva dela:

– front panel
– block diagram
 (*.vi) uvek startuje sa front panelom

Front Panel
korisnički interfejs

Block Diagram
Grafički kod

– Kontrole = Ulazi
– Indikatori = Izlazi

– Podaci “putuju” žicama  od kontrola 
preko funkcija do indikatora.



Front PanelFront Panel
korisnički interfejskorisnički interfejs

– Kontrole = Ulazi
– Indikatori = Izlazi

Front panel predstavlja korisnički interfejs 
programa.
Simulira panel fizičkog instrumenta.
Front panel sadrži:

– kontrole (okretna dugmad, klizači, tasteri,...)
– indikatore (grafikoni, displeji, skale,...)

 Kontole simuliraju ulazne delove uređaja i 
obezbjeđuju podatke za

block diagram vi programa.block diagram vi programa.

Indikatori simuliraju izlazne delove uređaja i 
služe za prikaz rezultata iz 

block diagram-a vi programa.

Svaki element front panela ima odgovarajući 
objekat u block diagramu.

Kontrole i indikatori dostupni su u okviru 
Controls palette front panela.



Dostupna je samo tokom rada na front panelu.

Ulaz/kontrola
Numeric

prilagođavanje 
izgleda palete

Controls PaletteControls Palette

Izlaz/Indicator:
Numeric Slide



Block DiagramBlock Diagram
Grafički kodGrafički kod

– Podaci “se prenose” žicama od 
kontrola preko funkcija do 
indikatora.

Blok dijagram je grafički prikaz tela 
programa.

Za razliku od front panela koji je 
namenjen korisniku, 
blok dijagram je namenjen programeru.

Grafičko programiranje se vrši 
kreiranjem blok dijagrama sa već kreiranjem blok dijagrama sa već 
gotovim funkcijama koje se nalaze u 
bibliotekama LabVIEW-a, gde se 
funkcije prilagođavaju potrebama 
podešavanjem izmenljivih parametara.

Glavni meni blok dijagrama u kome se 
nalaze funkcije – Functions pallete



Smeštanje elemenata
u Block Diagram prozoru

Dostupna je samo tokom rada na Blok dijagramu.

Functions PaletteFunctions Palette

While petlja



Palete su ispunjene stotinama kontrola i 
funkcija.

Kliknuti na taster za pretragu 

Pronaći željenu kontrolu ili funkciju

Pretraga kontrola i funkcijaPretraga kontrola i funkcija

Kliknuti i prevući objekat iz prozora za 
pretragu na blok dijagram/front panel.



Pri pisanju programa u LabVIEW-u se koriste sledeće tri palete: 
1. Controls (Front Panel / View » Controls Palette)
2. Functions (Block diagram / View » Functions Palette),
3. Tools (View » Tools Palette).

• PREPORUKA: Automatski izbor alatke
• Alati za rad i modifikaciju front panel i blok dijagram objekata.

Tools Palette

Operating Tool

Positioning/Resizing Tool

Labeling Tool

Wiring Tool

Automatic Selection Tool

 LabVIEV automatski bira odgovarajući alat sa palete Tools



Tools paletaTools paleta



Status ToolbarStatus Toolbar

Run Button 

Continuous Run Button

Abort Execution



Tehnike debagovanjaTehnike debagovanja

Run Button 
Prvi način

Greška u kodu    →   slomljena strelica
Klikom miša na strelicu pojavljuje se spisak grešaka u kodu

Drugi način
U Status Toolbar-u klikom miša na “lampicu”, a zatim 
Pokrenuti program i posmatrati Blok Dijagram. 
Iznad “žica”, terminala, iza funkcija i potprograma seIznad “žica”, terminala, iza funkcija i potprograma se
pojavljuju tekuće vrednosti. 
Rad programa u ovom modu je usporen što omogućava 
detaljno praćenje izvršavanja koda.

Treći način
U paleti Tools izborom Probe Tool koji se postavi 
ga na onu “žicu” čija vrednost se posmatra pri 
izvršavanju. 
Pokrenuti program i posmatrati vrednost koja se 
javlja u “letećem” Probe prozoru.



Pomoć pri radu / Help

Prvi način LabVIEW sadrži veliki broj gotovih primera do kojih se može doći 
na sledeći način: izabrati Help»Find Examples. 
Pretraga je moguća po tematskim jedinicama i po ključnim rečima.



Prvi način

Drugi način

LabVIEW sadrži veliki broj gotovih primera do kojih se može doći 
na sledeći način: izabrati Help»Find Examples.
Pretraga je moguća po tematskim jedinicama i po ključnim rečima.

Stati iznad funkcije za koju želite pogledati detaljnija 
objašnjenja i pritisnuti CTRL+H.

Pomoć pri radu / Help



Prvi način

Drugi način

LabVIEW sadrži veliki broj gotovih primera do kojih se može doći 
na sledeći način: izabrati Help»Find Examples.
Pretraga je moguća po tematskim jedinicama i po ključnim rečima.

Stati iznad funkcije za koju želite pogledati detaljnija 
objašnjenja i pritisnuti CTRL+H.

Pomoć pri radu / Help

Treći način Na sajtu National Instruments-a postoji link ka NI Developer zoni 
(zone.ni.com) gde se mogu naći gotova rešenja konkretnih 
problema.



PRIMER PRIMER 11

Primer 1Primer 1--a:a:

Kreirati virtuelni instrument koji:

1. Generiše testerasti signal.

2. Omogućava promenu amplitude signala iz Front panela.

LabVIEW sadrži ugrađene šablone virtuelnih instrumenata (templates) 
koji mogu iskoristiti za većinu jednostavnih aplikacija za merenje. 

Za rešenje primera 1 koristiće se upravo jedan ovakav šablon. 

3. Prikazuje signal na grafu Front panela.





Nakon odabira šablona pojavljuje se Front Panel... 



I ekran za kreiranje blok dijagrama virtuelnog instrumenta sa blokovima za 
generisanje i prikaz signala. 
Ovi blokovi su u odgovarajućoj sprezi sa kontrolama/indikatorima na Front 
Panelu. 



Blok Simulate Signal. 
Desnim klikom na simbol ovog bloka se selektuje Properties, gde se nakon 
toga pojavljuje ekran za izmenu atributa bloka.

1. Generisati testerasti signal



U okviru liste Signal Type izabrati tip generisanog signala Sawtooth što će 
rezultirati generisanjem testerastog signala.



 Dodavanje novih kontrola u okviru Front Panel-a se postiže selektovanjem 
odgovarajuće iz palete kontrola. 

2. Omogućiti promenu amplitude signala iz Front panela.



Kontrole su grupisane po kategorijama. 

U okviru Express kategorije selektovati Numeric Controls, a zatim odabrati 
dugme (Knob) kontrolu i postaviti je na površinu panela (npr . pored grafa). 



Dugme (Knob) će biti iskorišćen za promenu amplitude generisanog signala.
Na radnoj površini Block Diagram editora nakon svih akcija nalaze se 
blokovi kao na slici.



Blok za simuliranje signala sadrži atribute koji se prikazuju nakon 
proširenja blok Simulate Signal.



Povezivanje Knob kontrole sa Simulate Signal Amplitude atributom se vrši 
njihovim “ožičavanjem”  (uspostavljanjem veze).



Startovanjem programa sa Run se može videti uticaj Knob kontrole na 
amplitudu generisanog signala.



Primer Primer 11--b:b:

Na grafu Front panela prikazati:

(1) generisan trouglasti signal,

(2) kao i signal čija je amplituda 10 puta veća od signala (1).(2) kao i signal čija je amplituda 10 puta veća od signala (1).





Uređivanje Block diagrama i prilagođavanje kontrola Front panela



Express VI: (plavi okvir)

Standardni VI:

Tri vrste funkcijaTri vrste funkcija
(Functions Palette)(Functions Palette)

To su interaktivni VI koji imaju svoj 
dijalog prozor iz koga je korisniku 
omogućeno da konfiguriše Express VI .

Standardni VI:

Funkcije: (žute boje) Osnovni elementi pomoću kojih su izgrađeni svi 
blokovi VI. Funkcije nemaju front panel ili blok dijagram.



Koje funkcije su dostupne?



Koje funkcije su dostupne?
 Ulaz/Izlaz

– Simulacija signala i podataka
– Akvizicija i generisanje signala korišćenjem uređaja za 

akviziciju podataka (DAQ)

 Analiza
– Obrada signala
– Statistika– Statistika
– Primena složenih matematičkih formula

 Skladištenje
– Rad sa izlazno / ulaznim fajlovima



• Numerički podaci
– Numerički ulaz i izlaz

• Podaci Bulove logike
– Dugme i lampice

• Predstavljanje podataka
– numerički displej
– 2D grafikon

Express Controls Palette

KojKojee kkontrolontrolee i indikatori indikatorii su dostupni?su dostupni?

– 2D grafikon
– 3D grafikon

• Ukrašavanje
– strelice
– tabulatori

• Ostalo
– String and tekst boksovi



While While petljapetlja
• While petlje

– terminal broji iteracije
– Uvek se izvršava najmanje 

jednom
– Izvršava se dok uslov za 

PetljePetlje

• For petlje
– terminal broji iteracije
– Izvršava se N - puta
u skladu sa ulaznim terminalom

For For petljapetlja

– Izvršava se dok uslov za 
zaustavljanje nije ispunjen



Unošenje/crtanje petlje u blok dijagramUnošenje/crtanje petlje u blok dijagram

1. Izbor iz Functions palete 2. Ograditi kod koji se ponavlja



Primer upotrebe While petljePrimer upotrebe While petlje



1. Case Structura

(a) (b)

Donošenje odluka u LabVIEWDonošenje odluka u LabVIEW--uu

2. Select
(a) (b)

(c)



Pristup podacima iz prethodne petljePristup podacima iz prethodne petlje
Shift Registar Shift Registar 

Unosi se desnim klikom miša na levi ili desni okvir petlje i odabirom opcije
Add Shift Register .

Desni terminal čuva podatke nakon završetka iteracije.
Levi terminal obezbeđuje sačuvan podatak na početku naredne iteracijie.

Prva
iteracija

Druga
iteracija

Poslednja
iteracija

Krajnja 
vrednost

Inicijalna
vrednost 



Upisivanje u .Upisivanje u .LVM LVM fajlfajl Čitanje iz .Čitanje iz .LVM LVM fajlafajla

Ulazni i izlazni fajloviUlazni i izlazni fajlovi
 Omogućeno je snimanje podataka u fajl ili čitanje podataka iz fajla.



 Mogu se implementirati tekstualne jednačine i algoritmi.
 Ulazne i izlazne promenljive se kreiraju na levoj i desnoj granici ’’ čvora’’.
 Kompatibilan je sa m-file script jezikom.

Math Script čvor

(Functions»Programming»
Structures»MathScript)



Akvizicija podatakaAkvizicija podataka
hhardverardver

Hardver za akviziciju je komponenta koja može da obavlja sledeće funkcije:
 Konverziju ulaznih analognih signala u digitalni format,
 Konverziju digitalnih signala u analogni format (izlaz),
 Generisanje digitalnih izlaznih signala.

 Uređaji za akviziciju podataka
(Data Acquisition Device - DAQ)

– USB, PCI ili PXI uređaji
– Konfigurišu se i testiraju u MAX-u

(Measurement & Automation Explorer)

 Zvučna kartica
– Ugrađena u većinu računara



Koji uređaj izabrati?Koji uređaj izabrati?

Sound Card NI USB DAQ NI PCI DAQ

AI Bandwidth 8–44 KS/s 10–200 KS/s 250 K–1.2 Ms/s
Accuracy 12–16 bit 12–16 bit 14–18 bit
Portable x x —
AI Channels 2 8–16 16–80
AO Channels 2 1–2 2–4

NI USB-6009 SPECIFIKACIJA:
• 8  (14-bit) analognih ulaza
•12  digitalnih I/O linija
• 2   analogna izlaza



Akvizicija podataka u LabVIEWAkvizicija podataka u LabVIEW

Labview funkcije za akviziciju podataka (Data Acquisition VIs) se mogu
podeliti na:

- Express VIs (DAQ Assistant) i
- Standard VIs (DAQmx VIs).

Express VIs (DAQ Assistant)Express VIs (DAQ Assistant)Express VIs (DAQ Assistant)Express VIs (DAQ Assistant)

 DAQ Assistant konfiguriše DAQ task korak po korak u nekoliko
konfiguracionih prozora. 



DAQmxDAQmx VVIIss

 Kada je brzina izvršavanja kritična, 
preporučuje se korišćenje
DAQmx VIs za akviziciju podataka. 

 DAQmx VIs obuhvataju funkcije za
počinjanje i zaustavljanje akvizicije, 
čitanje i upis akvizicionih podataka.



Kreiranje virtuelnog voltmetraKreiranje virtuelnog voltmetra

Front panel

Block diagram



Formira virtuelni kanal

Block diagramBlock diagram

Formira virtuelni kanal
(AI Voltage)

Započinje merenje
Ponavlja podprogram – While petlja

Očitavanje podataka
Wait until next ms multiple

Zaustavlja merenje
Ukoliko dođe do greške, pojavljuje 
se dijalog boks sa informacijom o 
grešci koja se dogodila.



Zašto koristiti LabVIEW?Zašto koristiti LabVIEW?

Jednostavan za učenje

Jednostavan za primenu

Programski kod je u vidu šeme

Nema sintakse!!!

Jednostavno i brzo ispravljanje grešaka 

Prilagodljiv


